重庆思庄Oracle、Redhat认证学习论坛

 找回密码
 注册

QQ登录

只需一步,快速开始

搜索
查看: 64|回复: 0

[升级] lib64/libc.so.6: version `GLIBC_2.14 not found

[复制链接]
发表于 2021-9-4 22:50:37 | 显示全部楼层 |阅读模式
问题描述:11g升级19c调图形界面时,报错lib64/libc.so.6: version `GLIBC_2.14 not found,无法弹出图形界面.
造成这种异常的原因是程序运行需要GLIBC_2.14,而当前系统不存在.
用strings /lib64/libc.so.6 | grep GLIBC_语句发现系统最高版本为GLIBC_2.13
处理方案:下载安装包glibc-ports-2.14.tar与glibc-2.14.tar,传送到虚拟机中
然后依次执行以下语句:
tar -xvf  glibc-2.14.tar.gz   
tar -xvf  glibc-ports-2.14.tar.gz  
mv glibc-ports-2.14 glibc-2.14/ports     
mkdir glibc-build-2.14
cd glibc-build-2.14
../glibc-2.14/configure  --prefix=/usr --disable-profile --enable-add-ons --with-headers=/usr/include --with-binutils=/usr/bin
make
make install
其中在执行make与make install语句时需等待一定时间.
结束后用strings /lib64/libc.so.6 | grep GLIBC_语句检查GLIBC版本.
可以看到已安装GLIBC-2.14
1.png
此后便能正常调出图形界面.

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则

QQ|手机版|小黑屋|重庆思庄Oracle、Redhat认证学习论坛 ( 渝ICP备12004239号-4 )

GMT+8, 2021-9-22 14:06 , Processed in 0.095795 second(s), 24 queries .

重庆思庄学习中心论坛-重庆思庄科技有限公司论坛

© 2001-2020

快速回复 返回顶部 返回列表