重庆思庄Oracle、Redhat认证学习论坛

 找回密码
 注册

QQ登录

只需一步,快速开始

搜索
查看: 2828|回复: 1

关于Linux主机网卡绑定模式与交换机端口对接注意事项

[复制链接]
发表于 2016-8-24 16:47:06 | 显示全部楼层 |阅读模式
本帖最后由 LuckyYang 于 2016-8-24 16:53 编辑

当Linux主机网卡做好Bond绑定之后,将会设置转发模式如下:(Linux主机网卡绑定Bond见下贴“关于创建Linux主机网卡绑定”)
vim /etc/modprobe.conf  //打开网卡绑定文件
alias eth0 igb
alias eth1 igb
alias eth2 igb
alias eth3 igb
alias scsi_hostadapter megaraid_sas
alias scsi_hostadapter1 usb-storage
alias scsi_hostadapter2 qla2xxx
alias scsi_hostadapter3 qla2xxx
alias usb0 cdc_ether
alias usb1 cdc_ether
alias bond0 bonding
alias bond1 bonding
options bond0 mode=4 miimon=100 lacp_rate=1  //找到bond口设置模式mode这里,填写正确的bond模式,这里为4
options bond1 mode=1 miimon=100                   //找到bond口设置模式mode这里,填写正确的bond模式,这里为1

###BEGINPP
include /etc/modprobe.conf.pp
###ENDPP

miimon 监视网络链接的频度,单位是毫秒,我们设置的是100毫秒。

保存后,配置bond即为完成


------------下面解析bond模式的种类---------------------
mode bond模式,主要有以下几种,在一般的实际应用中,0,1和6 用得比较多

模式0或balance-rr 轮转策略,提供负载均衡和高可用性,按顺序轮流把包发给包含在bond口内的网口。

模式1或active-backup,主备策略,提供高可用性,逻辑简单,一个处于激活状态,一个失败,另外一个自动激活。

模式2或balance-xor,XOR策略,提供负载均衡和高可用性。

模式3或broadcast,广播策略,把数据以广播的方式,发给包含在该bond口内的所有网口

模式4或802.3ad, IEEE 802.3ad动态链接集合。

模式5或balance-tlb ,自动适应传输负载均衡策略。

模式6或balance-alb ,自动适应负载均衡策略。

-------下面解释在bond网卡与交换机聚合组端口进行连接时的注意--------
注:常见主流的交换机,当端口加入聚合组时,该聚合组的端口模式为静态;注只有当Mode模式为04时,才需要交换机在端口上做支持。
mode bond模式:常见的主机绑定端口多为偶数个。

mode=0时,主机两个端口同时工作、同时发包,所以在交换机上需要将所连接的两个口绑定为一个聚合组(Cisco或者ZTE叫做ethernet channel,H3C或者Huawei叫做 link-aggregation),这个时候当两个端口加入交换机的聚合组后,即为绑定,在交换机上聚合组的模式STATIC。这时主机与交换机之间就能正常工作了。

mode=1时,主机上的端口同时工作、轮流发包,不需要所连接的交换机做任何操作。

mode=2时,主机上的端口都试行balance-xor XOR策略,提供负载均衡和高可用性;不需要所连接的交换机做任何操作。

mode=3时,主机上的端口广播的方式,发给包含在该bond口内的所有网口;不需要所连接的交换机做任何操作。

mode=4时,主机上的端口以IEEE 802.3ad动态链接集合协议进行工作,所以在交换机上需要将所连接的两个口绑定为一个聚合组(Cisco或者ZTE叫做ethernet channel,H3C或者Huawei叫做 link-aggregation),而且交换机上的聚合组必须开启为Dynamic LACP模式,才能与交换机系统工作,当端口处于LACP时,还需要与主机进行从源到目的的传输配置,目前常见的有4种模式:从源MAC到目的MAC,从源MAC到目的IP,从源IP到目的MAC,从源IP到源IP。常见的设置模式为从源MAC到目的MAC和从源IP到源IP这两种,此时需要分析主机上运行的软件或者程序是工作在ISO二层还是三层的(关于ISO七层模型的详解请见“ISO七层模型详解”),当是工作在2层的时候用从源MAC到目的MAC的LACP模式,当是工作在3层的时候则用从源IP到目的IP的LACP模式。
注:两大类型的交换机LACP配置方式;
1.Cisco类:
sw1(config-if-range)#channel-protocol lacp
sw1(config-if-range)#channel-group 1 mode active
如果想把端口配置为LACP的passive:
sw1(config-if-range)#channel-protocol lacp
sw1(config-if-range)#channel-group 1 mode passive
sw1#show etherchannel summary        //查看EtherChannel信息
EtherChannel说明:
①Cisco最多允许EtherChannel绑定8个端口;
1>如果是快速以太网,总带宽可达1600Mbit/s;
2>如果是Gbit以太网,总带宽可达16Gbit/s。
②EtherChannel不支持10M端口;
③EtherChannel编号只在本地有效,链路两端的编号可以不一样;
④EtherChannel默认使用PAgP协议;(Cisco私有协议)
⑤EtherChannel默认情况下是基于源MAC地址的负载平衡;
⑥一个EtherChannel内所有的端口都必须具有相同的端口速率和双工模式,LACP只能是全双工模式;
⑦channel-group接口会自动继承最小物理接口,或最先配置的接口模式;
⑧cisco的交换机不仅可以支持第二层EtherChannel,还可以支持第三层EtherChannel。

2.H3C类:
///将g1/0/12和g2/0/12加入聚合组90
interface GigabitEthernet1/0/12
port link-mode bridge
port link-type trunk
undo port trunk permit vlan 1
port trunk permit vlan 2 to 4094
mirroring-group 3 mirroring-port both
port link-aggregation group 90
interface GigabitEthernet2/0/12
port link-mode bridge
port link-type trunk
undo port trunk permit vlan 1
port trunk permit vlan 2 to 4094
mirroring-group 3 mirroring-port both
port link-aggregation group 90
///将聚合组90设置为dynamic模式,即为LACP模式;并配置从源IP到目的IP的LACP模式。
interface Bridge-Aggregation90
description to RP-VM-01
port link-type trunk
undo port trunk permit vlan 1
port trunk permit vlan 2 to 4094
link-aggregation mode dynamic
link-aggregation load-sharing mode destination-ip source-ip

link-aggregation说明:
①dynamic模式默认就为LACP模式
②默认情况下是基于源MAC地址到目的MAC地址的负载平衡


mode=5时,主机上的端口施行balance-tlb协议,自动适应传输负载均衡策略;不需要所连接的交换机做任何操作。

mode=6时,主机上的端口施行balance-alb协议,自动适应负载均衡策略;不需要所连接的交换机做任何操作。


本文为作者累积的知识梳理,如有错误的情况请尽快通知我,以免误导大家,谢谢!
QQ:279575705

回复

使用道具 举报

 楼主| 发表于 2016-8-24 16:48:37 | 显示全部楼层
自己先顶一发,今年事情确实经历太多,到年底来才能静下心来好好地整理和梳理知识,并分享给大家,太长时间没冒泡了,出来晃一晃!:-)
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则

QQ|手机版|小黑屋|重庆思庄Oracle、Redhat认证学习论坛 ( 渝ICP备12004239号-4 )

GMT+8, 2022-12-2 00:15 , Processed in 0.093542 second(s), 20 queries .

重庆思庄学习中心论坛-重庆思庄科技有限公司论坛

© 2001-2020

快速回复 返回顶部 返回列表